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1 Introduction to Omnixx Force 
 
 
 
 
Welcome to Omnixx™ Force, the desktop application module of the new Omnixx™ Suite of 
products from Datamaxx Applied Technologies, Inc. Omnixx Force works from within your 
agency’s network to provide browser-based functionality that meets the specific needs of today’s 
law enforcement community. It allows users to send and receive text-based messages over 
dedicated law enforcement networks. These messages can be of an administrative nature or 
contain data elements for insertion into local, state, and federal databases.  
 

 
Figure 1.1 The Omnixx Force User Interface 

   
Every time a user accesses the Omnixx Force application, it will synchronize with the Omnixx™ 
Application Repository and automatically update any changes that have been made to forms, 
help files, code tables, etc. This will ensure that the user always has the most up-to-date version 
of all transaction forms. 
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A few of the key features available in Omnixx Force include: 
 

� User-friendly Transaction Forms that include features such as Pop-Up Code Boxes, Field 
Help, and Mandatory Field identification. 

 

 
Figure.1.2 The Omnixx Force “QG” Transaction Form 

 
� A Message Window that allows for simultaneous printing or deleting of multiple 

messages. Also, information contained in messages can easily be forwarded by way of an 
Administrative Message. 

 

 
Figure 1.3 The Omnixx Force Message Window 
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� A Message Log that allows the user to easily search for messages that have been deleted 
from the Message Window. The Message Log also allows the user to enter search criteria 
to narrow down the search for quick results. 

 

  
Figure 1.4 The Omnixx Force Message Log 

 
� A Command Bar that allows the user to quickly retrieve transaction forms without having 

to search through the entire Forms menu. 
 

 
Figure 1.5 The Omnixx Force Command Bar 

 
Now that you have had an initial introduction to Omnixx Force and a few of its key features, the 
remainder of this chapter will give you a brief overview of some basic Windows functions and 
how to use the web browser (Windows® Internet Explorer and Netscape® Navigator) for those 
who might not be familiar with these applications. Becoming familiar with both Windows and 
the web browser will help you maneuver more easily through the Omnixx Force application. If 
you are already familiar with these products, please proceed to “Chapter 2 – Getting Started in 
Omnixx Force”. 
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1.1 Using Windows 
 
This section provides instructions on using the mouse, selecting menu items and completing 
dialog boxes. First, you should look over the list of Windows basics listed below. If you are not 
sure of any of these procedures, please spend some time getting to know Windows. The first 
several chapters of the Windows User’s Guide will give you enough basics to get started in 
Omnixx Force. The more proficient you are in Windows, the easier it is to utilize Omnixx Force 
to its full potential. 
 
 
1.2  Windows Basics 
 

� Moving, minimizing, maximizing, activating, and closing windows. 
 

� Choosing commands (from command menus) and completing dialog boxes. 
 

� Clicking, double-clicking, and dragging objects with the mouse. 
 

� Using the scroll bars, direction keys and navigation keys to move around in Windows. 
 
Using the Mouse 
 
This manual uses the term “mouse” to indicate a pointer. The mouse is a tool that is used for 
moving the cursor, or pointer, on the screen. Slide the mouse around on a flat surface or mouse 
pad to move the pointer. The best way to understand how the mouse works is to practice using it. 
 
There are usually only two buttons (right and left) on the top of the mouse. Always use the left 
mouse button unless specifically told to use the right mouse button. If your mouse has three 
buttons, ignore the middle button when using Omnixx Force.  
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The following terms and their meanings describe how this manual refers to using the mouse. 
 
 

When You See: Using the Mouse: 

Click on, or choose 

 
Place the pointing arrow at the 
desired location, then press and 
quickly release the left button. 

 

Double-click 
Place the pointing arrow at the 
desired location, then quickly 
press and release the button 
twice. 

Right-click 
Place the pointing arrow at the 
desired location, then press and 
quickly release the right button. 

Drag Press and hold the left button as 
you move the pointer. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Using Dialog Boxes 
 
A dialog box is a standard Windows feature that provides information about program or system 
settings and allows you to change these settings. A dialog box may be presented when you 
choose a command.  
 

 
Figure 1.6 Datamaxx Dialog Box Tutor 
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To Navigate Through a Dialog Box: 
 

� Use the TAB key to move forward through the fields and boxes in the dialog box. 
 

� Use SHIFT + TAB to move backwards through the fields and boxes. 
 

� CTRL + TAB moves the cursor to the first field in the previous group. 
 

� CTRL + HOME moves the cursor to the first field in the form, and CTRL + END moves the 
cursor to the last field in the form. 

 
� You can also use your mouse to point and click into any field. 

 
� To close a dialog box without saving the changes, click CANCEL. 

 
� To close a dialog box and save changes, click OK. 

 
Types of Fields in a Dialog Box 
 
Please refer to Figure 1.6 for examples of the different fields listed below.  
 

Entry Boxes 
Entry boxes allow you to enter appropriate data into a field. For example, entering the 
name of a wanted person into an Omnixx Force form. Make sure the cursor is in the 
desired box and then type the text or characters. 
 
Check Boxes 
Check boxes allow you to activate or deactivate a specific option. Put the mouse pointer 
in the box and click the left mouse button. This will check (activate) or uncheck 
(deactivate) the box. 
 
Radio Buttons 
Radio buttons usually appear in groups. You may select only one option in the group. Put 
the mouse pointer on the circle, and then click the left mouse button to select the desired 
option. To change the current setting, simply click another option in the group. 
 
List Boxes 
List boxes provide you with a list of possible entries for the field. Put the mouse pointer 
on the down arrow to the right of the box, and then click the left mouse button. The list of 
possible entries drops down from the box. To select an item from the list, double-click on 
the item and the item you selected appears in the list box. 
 
Command Buttons 
Command buttons control the status of the entire dialog box. Put the mouse pointer on the 
face of the command and click on the left mouse button, or TAB through the commands 
until the desired command is highlighted, then press ENTER. 
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Using the Keyboard  
 
Although you will generally use the mouse to activate Windows controls, you often have the 
ability to activate a control by using the keyboard at the same time. Whenever a control label has 
an underlined character, you may activate that control by pressing and holding the ALT key while 
pressing and releasing the keyboard character which is underlined. 
 
For example, in the Tools menu, the “T” is underlined. Therefore, the Tools menu may be 
activated by holding down the ALT key and pressing the “T” key on the keyboard. Once the 
menu drops down, use your arrows on the keyboard to scroll down to the desired command and 
press ENTER, or simply press the key on the keyboard for the underlined letter of the command 
you wish to activate. For our example below, if you want to activate the Message Window, you 
would press the “W” key on the keyboard. 
 

 
Figure 1.7 Tools Menu 

 
Application Window 
 
Once an application is started, it is displayed in its own application window. This window can be 
moved around, resized, or even minimized into an icon on the task bar. Several applications can 
be running at the same time, and each is displayed in its own window. Each application window 
has a Title Bar at the top that tells you which application is being displayed. There is also a set 
of resizing buttons on the far right of the title bar. You may also resize a window by placing your 
pointer on the far right edge, bottom edge, or bottom right corner of the window, then click and 
drag that border to wherever you like. 
 

 

Minimize Button Close ButtonTitle Bar 

Maximize Button 

Figure 1.8 Omnixx Force Application Window 
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If a user clicks on the Minimize Button, the application will no longer be seen in the 
Application Window, but will be minimized into an icon on the Task Bar (see Figure 1.9). The 
application may be returned to its original size by clicking the icon on the Task Bar. 
 
 
 

 

Omnixx Force 

Figure 1.9 Omnixx Force Minimized into an Icon 
 
 
1.3 Browser 
 
The Web Browser is a software program used to access and display information from the 
Internet, thus acting as the interface for Omnixx Force. This section will detail some of the most 
common functions of Internet Explorer and Netscape Navigator to assist the novice user. 
 
 
1.3.1 Browser Anatomy and Functions 
 
This subsection illustrates the graphical layouts and briefly describes the basic functions of 
Internet Explorer and Netscape Navigator. The layout may vary slightly, or some functions may 
not be present, depending on what specific browser version is currently is use. For a more 
detailed description of the specific browser’s capabilities, consult the documentation that came 
with the browser or the Help file located in the Help drop-down list at the top of the browser’s 
interface. 
 
Toolbar 
 
The figures below display the Internet Explorer and Netscape Navigator Toolbars. This interface 
contains a selection of buttons and menus listed and described in this section. 
 

 
Figure 1.10 Internet Explorer Toolbar 

 

 
Figure 1.11 Netscape Navigator Toolbar 
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1.3.2 Setting the Omnixx Desktop as the Home Page 
 
Internet Explorer 
 
Setting the Omnixx Login as your home page allows Internet Explorer to load the Omnixx Login 
screen automatically when the browser is opened. After logging in, the Omnixx Desktop will be 
displayed. You can then easily access the Omnixx Force application. To configure this option, 
click Tools (located on the Menu Bar), then select Internet Options… The Internet Options 
dialog box will be displayed (see Figure 1.12). 
 

 
Figure 1.12 Internet Options Dialog 

 
In the Home Page section, enter the Omnixx Login web address into the Address text box, then 
click OK (if unknown, obtain the Omnixx Login web address from your System Administrator). 
The Omnixx Login screen has now been set as your Home Page. 
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Netscape Navigator 
 
Setting the Omnixx Login as your home page allows Netscape Navigator to load the Omnixx 
Login screen automatically when the browser is opened. After logging in, the Omnixx Desktop is 
displayed. You can then easily access the Omnixx Force application. To configure this option, 
click Edit located on the Menu Bar, then select Preferences…. The Preferences dialog box is 
displayed (see Figure 1.13). 
 

 
Figure 1.13 Edit Preferences Dialog 

 
In the Home Page section, enter the Omnixx Login screen web address into the Location text 
box, and click OK (if unknown, obtain the Omnixx Login web address from your System 
Administrator). The Omnixx Login has now been set as your home page. 
 
Using Navigation Buttons on the Browser 
 
If Internet Explorer is installed on your computer, please refer to the buttons pictured on the left 
in the following figures. If Netscape Navigator is installed on your computer, please refer to the 
buttons pictured on the right side. 
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Back Button 
 
Click the Back button to return to the previous web page. 
 

  
Figure 1.14 Back Buttons 

 
Forward Button 
 
Click the Forward button to return to the web page that was previously viewed. 
 

  
Figure 1.15 Forward Buttons 

 
Stop Button 
 
Click the Stop button to stop the browser from loading the current page. This is useful if the 
page is taking too long to load and the user wishes to visit an alternate web page. 
 

            
Figure 1.16 Stop Buttons 

 
Refresh/Reload Buttons 
 
Click the Explorer Refresh button or Navigator Reload button to load the web page again. 
While loading a web page, a file transfer may be interrupted, preventing all of the visual page 
elements from loading. The Refresh/Reload button reloads the page to correct this. In addition, 
the Refresh/Reload button will load the most recent version of a currently viewed web page if it 
is a page that is updated frequently. 
 

            
Figure 1.17 Refresh/Reload Buttons 

 
Home Button 
 
Click the Home button to return to the configured home page. For more on setting your browser 
to have Omnixx Force as your home page, please refer to the Section 1.3.2 on “Setting Omnixx 
Force as the Home Page” earlier in this chapter. 
 

  
Figure 1.18 Home Buttons 
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Search Button 
 
The Search button loads search engines located at the web sites of either Microsoft or Netscape, 
depending on the browser being used and the type of Internet connection in place. These search 
engines are used to search the Internet for information. 
 

  
Figure 1.19 Search Buttons 

 
Print Button 
 
The Print button prints a copy of the current web page, if the computer has access to a printer. 
 

  
Figure 1.20 Print Buttons 

 
Favorites/Bookmarks Button 
 
The Explorer Favorites button and the Navigator Bookmarks button allow the user to store a 
web address that he/she plans to visit again. While viewing the desired web page, click the 
Favorites/Bookmarks button and a dialog will guide the user in adding the address to the list. 
To revisit a stored address, click the Favorites/Bookmarks button and select the appropriate 
web page. 
 

  
Figure 1.21 Favorites/Bookmarks Buttons 
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2 Getting Started in Omnixx Force  
 
 
 
2.1 Accessing Omnixx Force 
 
To start the Omnixx Force application, you must first access the Omnixx Login screen. In order 
to do this, double-click on the browser icon located on your computer’s desktop. The icon should 
be for either Internet Explorer or Netscape Navigator. If you followed the directions in the 
Introduction on setting the Omnixx Login as your Home Page, the browser should automatically 
take you to the Omnixx Login screen. If the Omnixx Login is not configured as your Home Page, 
you must type the URL (web address) into the browser’s address bar. Also, keep in mind that 
your computer may already be configured with a shortcut icon for the Omnixx Login screen. If 
this is the case, simply double-click the icon to proceed. 
 

 
Figure 2.1 The Omnixx Login Screen 

 
If this is the first time you are accessing Omnixx Force on your computer, you will have to 
download and run the correct version of the Java Runtime Environment and the Web Start 
application. Click the “First time users click here to install the Java Runtime” link located at 
the bottom of the Omnixx login screen. You will be prompted with the following warning: 
 

 
Figure 2.2 Java Runtime Warning Screen 
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Click the OK button to proceed. The following dialog box will appear and prompt you with 
directions to complete the next step. Click OK to continue to the next step in the installation 
process. 
 

 
Figure 2.3 Java Runtime Instruction Dialog Box 

 
You will see a File Download dialog box similar to that shown in either Figure 2.4.1 or 2.4.2. If 
the dialog box, shown in Figure 2.4.1 appears, select “Run this program from its current 
location”, then click the OK button to continue. 
 

 
Figure 2.4.1 File Download Dialog Box 
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If the dialog box shown in Figure 2.4.2 appears, click the Open button. 
 

 
Figure 2.4.2 File Download Dialog Box 

 
The following progress meter is displayed: 
 

 
Figure 2.5 Java Progress Meter Dialog Box 
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You may be prompted with a Security Warning (Figure 2.6). You must click the Yes button to 
continue. If you click No, the installation process will terminate immediately. 
 

 
Figure 2.6 Security Warning 

 
The Java Web Start License Agreement is displayed (Figure 2.7). Read the agreement and click 
the Accept button to continue the installation process. If you choose not to accept the license 
agreement, click Decline and the installation process will terminate immediately. 
 

 
Figure 2.7 Java Web Start License Agreement 
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Next, you are prompted to enter the path of the directory where you would like the Java Web 
Start application installed. You may leave the path at the default, or click the Browse button to 
select a different location. Click the Next button to continue. 
 

 
Figure 2.8 Java Web Start Select Installation Directory Screen 

 
The Java Web Start files will be installed to the path specified in the previous step. The 
following dialog box is displayed to indicate the progress of the installation. 
 

 
Figure 2.9 Java Web Start Installation Progress Meter 
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After the Java Web Start files are installed, the client machine is searched to ensure that the 
correct version of the Java 2 Runtime Environment has been installed. If not, you will be 
prompted to select the path where you would like this program installed. You may leave it at the 
default path and simply click OK, or click the Browse button to select an alternate directory. 
Click OK to continue. 
 

 
Figure 2.10 Java 2 Runtime Environment Installation Directory Screen 

 
You will be notified when the installation is complete and you may choose whether or not you 
would like to read the on-line help manual for Java.  Click Yes to view the manual, or click No if 
you prefer to skip the manual and login to the Omnixx Desktop.  
 

 
Figure 2.11 View Java Online Manual Selection 
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Now that both Java Web Start and the correct version of the Java Runtime Environment have 
been installed on the client machine, you are ready to login to the Omnixx Desktop.  
 

  
Figure 2.12.1 The Omnixx Login Screen 

 
On the Omnixx Login screen, you are prompted to enter the following information. All of the 
information is retained by the system, except the Password, so that all of this information will not 
have to be entered upon every login to the Omnixx Desktop. 
 

� User ID – Enter your Username. 
 
� Password – Enter your Password. 
 
� Agency – Enter your agency’s identifier. (The identifier can be configured to be the 

agency name, agency ORI, etc.) 
 
� Validation Code – Enter your assigned Validation Code (if required). 

 
� Omnixx Path – Enter the drive letter and/or path to which you would like the Omnixx 

directory installed (e.g., C:\NC\Omnixx). 
 

� New Password – Enter a new password if you wish to change your current password. 
 

� Confirm – Re-enter your new password. 
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If the Agency, Validation Code, and Omnixx Path fields are hidden as in Figure 2.12.2, click the 
link labeled “click here for more details” to display all fields.  
 

 
Figure 2.12.2 The Omnixx Login Screen 

After all necessary information is entered correctly, click the “Log In” icon  to begin the 
login process. The Omnixx Certifications window appears with a listing of the user’s current 
certification status. Click Close to exit the Certifications window and display the Omnixx 
Desktop. 
 

 
Figure 2.13 The Omnixx Certifications Window 
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Once you are logged into the Omnixx Desktop, you will be able to access all of the Omnixx 
applications you are authorized to use directly from the Desktop, avoiding the need to logon to 
each application separately. 
 

 
Figure 2.14 The Omnixx Desktop 

 
Locate the Omnixx Force icon and click it to access the application. 
 

 
Figure 2.15 The Omnixx Force Icon 
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After selecting the Omnixx Force application, the Java Web Start program will start and the 
following progress meter is displayed: 
 

 
Figure 2.16 Java Web Start Progress Meter 

 
Next, the Java Web Start Security Warning is displayed. You must click the Start button to 
proceed with loading the Omnixx Force application. This warning will only appear upon the 
initial Omnixx logon. 
 

 
Figure 2.17 Java Web Start Security Warning 

 

Datamaxx Applied Technologies, Inc.  22 



 Omnixx Force Training Manual                                                Version 1.0           

At this time, Omnixx Force will synchronize with the Omnixx Application Repository to ensure 
that your computer has the most current version of all transaction forms available. If not, the 
system will automatically update them for you. As this is taking place, you will see the following 
status screen: 
 

 
Figure 2.18 Update Status Screen 

 
Once synchronization with the Omnixx Application Repository is complete, the Omnixx Force 
user interface is displayed, and you are ready to begin. 
 

 
Figure 2.19 Omnixx Force User Interface 
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2.2 Exiting the Omnixx Desktop 
 
If you wish to log out of Omnixx completely, locate and click the Exit icon on the Omnixx 
Desktop. 

 

 
Figure 2.20 Exit Omnixx Desktop 

 
Once you click on the Exit icon on the Omnixx Desktop, you are prompted with the 
Confirmation dialog box. Click Yes if you wish to exit the Omnixx Desktop, or click No if you 
decide not to exit. 
 

 
Figure 2.21 Omnixx Desktop Logoff Confirmation 
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3 Elements of the Omnixx Force 
User Interface 

 
 
 
There are several elements of the User Interface that you will want to become familiar with 
before using Omnixx Force. These elements include:  
 

� Menu Bar 
� Toolbar 
� Command Bar 
� Status Bar 

 
The following chapter describes all four of these elements and their functions in great detail. 
Once you understand these elements and their functions, you will be well on your way to 
becoming an expert user of Omnixx Force. 
 
 

 

Toolbar 

Menu Bar

Command Line 
Status Bar 

Figure 3.1 Omnixx Force User Interface 
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3.1 The Menu Bar 
 
The Omnixx Force Menu Bar, which is located below the Title Bar, consists of nine menu items: 
File, Forms, Edit, Comm, Options, Tools, Windows, Links, and Help. Each menu contains a 
drop-down list of commands that relate to that particular menu item. For example, to find help 
with an Omnixx Force function, click the Help menu and several help options will be displayed. 
For a detailed explanation of the commands found in the Omnixx Force menu, please see the 
following subsections. 
 

 
Figure 3.2 Omnixx Force Menu Bar 

 
 
3.1.1 The File Menu 
 

 
Figure 3.3 Omnixx Force File Menu 

 
� Print Setup – Opens the Print Setup dialog box, which allows the user to enter the path 

of the network printer he/she wishes to send and print Omnixx Force messages. 
 

 
Figure 3.4 Print Setup Dialog Box 

  
� Exit - Closes the Omnixx Force User Interface. 
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3.1.2 The Forms Menu 
 

 
Figure 3.5 Omnixx Force Forms Menu 

 
� A cascading menu of all forms that are accessible to the user are displayed in this menu. 

This menu will vary depending on certifications held by the current user. 
 

3.1.3 The Edit Menu 
 

 
Figure 3.6 The Edit Menu 

 
� Cut - This option allows a user to remove selected text from the message window and 

place it into another application. Highlight the desired text and click the Cut command. 
The highlighted text is placed on an imaginary “clipboard” and may now be pasted into 
another application. 

 
� Copy - This option allows a user to make a copy of selected text from the message 

window and place it into another application. Highlight the desired text and click the 
Copy command. A copy of the highlighted text is placed on an imaginary “clipboard” 
and may now be pasted into another application. 

 
� Paste - The Paste function works in conjunction with the Cut and Copy commands. After 

text has been either cut or copied from an application, the text can be transferred to 
another application by placing the cursor at the desired location and clicking the Paste 
command. The text that was on the imaginary “clipboard” is now placed at the cursor 
location. 
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3.1.4 The Comm Menu 
 

 
Figure 3.7 The Comm Menu 

 
� Transmit – This function sends the current transaction form to the host for processing. 
 
 

3.1.5 The Options Menu 
 

 
Figure 3.8 The Options Menu 

 
� Auto Switch to Message Window – When enabled, the Message Window will 

automatically open whenever a message is received. 
 

� Auto Print - When this feature is enabled, all incoming messages are printed without any 
necessary action from the user. 

 
� View Command Bar –This option toggles off and on the Command Bar at the bottom of 

the screen. 
 

� Write Trace File – When activated, this option generates a trace file that can be used to 
diagnose system problems. Clicking the Trace File Indicator  on the status bar may 
also activate this option.  

 
� Check For Form Updates – When activated, Omnixx Force will automatically query the 

repository every time a form is opened to check for any updates that may have been made 
to that particular transaction form. 
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3.1.6 The Tools Menu 
 

 
Figure 3.9 The Tools Menu 

 
� Synch Rules with the Repository – Deletes the entire Omnixx DMML sub-directory 

from the local computer and downloads all files from the repository to ensure that all 
files are current. When activated, the following dialog box is displayed: 

 

 
Figure 3.10 Synch Rules with Repository Confirmation 

 
� Message Window - Opens the Omnixx Force Message Window where the user can view 

all messages from the current session. Please see Chapter 5 – “The Omnixx Force 
Message Window, Message Display and Message Log” for more detailed information on 
the Message Window. 

 

 
Figure 3.11 Omnixx Force Message Window 
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� Message Log – Opens the Message Log feature allowing the user to search and view 
messages that were sent and received during previous sessions of Omnixx Force. The 
Message Log is described in greater detail in Chapter 5 – “The Omnixx Force Message 
Window, Message Display and Message Log”. 

 

 
Figure 3.12 Omnixx Force Message Log 

 
 
3.1.7 The Windows Menu 

  

 
Figure 3.13 The Windows Menu 
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� Cascade – Diagonally aligns all open transaction forms, one in front of the other, with 
the title bars showing. The top window is active, while the underlying windows are 
inactive. To bring an inactive window to the foreground, click on its title bar. 

 

 
Figure 3.14 Cascaded Transaction Forms 

 
� Tile Horizontally – Aligns all open transaction forms one on top of the other. This 

allows for simultaneous viewing of all open forms. 
 

 
Figure 3.15 Transaction Forms Tiled Horizontally 
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� Tile Vertically – Aligns all open transaction forms side-by-side. This allows for 
simultaneous viewing of all open forms.  

 

 
Figure 3.16 Transaction Forms Tiled Vertically 

 
� Close – Closes the currently active transaction forms. 

 
� Close All - Closes all open transaction forms in the Omnixx Force interface, but does not 

exit the program. 
 

� Forms – Opens a dialog box that contains a list of all currently open transaction forms. 
 

 
Figure 3.17 Forms Dialog Box 
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3.1.8 The Links Menu 
 

 
Figure 3.18 The Links Menu 

 
� Displays a list of links to helpful websites that are specific to your state/agency. 

 
3.1.9 The Help Menu 
 

 
Figure 3.19 The Help Menu 

 
� Standard Documents – Opens the Documents submenu that includes links to the 

following items: 
 

o NCIC User’s Manual – Opens the on-line NCIC User’s Manual. 
 

o NLETS User’s Guide – Opens the on-line NLETS User’s Guide. 
 

o Omnixx User’s Manual – Opens the on-line Omnixx Force Help Manual. 
 

� Datamaxx Applied Technologies, Inc. – Opens the Datamaxx website using your 
computer’s default browser. 
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� About Omnixx Force – Opens the “About Omnixx Force” dialog box pictured below 
that displays information regarding the version of Omnixx Force currently being used, 
Technical Support contact information, and system configuration properties. 

 

 

A 

B 

C 

D 

Figure 3.20 “About Omnixx Force” Dialog Box 
 

A. Version - Version number of the Omnixx Force application. 
 
B. Support – Click here for the Datamaxx Technical Support contact number. 

 

 
Figure 3.21 Technical Support Contact Number 
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C. Properties – Opens the following “Omnixx Configuration Properties” window that 
provides configuration information regarding the local client. 

 

 
Figure 3.22 Omnixx Configuration Properties Window 

 
D. OK - When activated, the “About Omnixx Force” window is closed, and the user will 

be returned to the Omnixx Force user interface. 
 
 

3.2 The Toolbar 
 

 
Figure 3.23 Omnixx Force Toolbar 

 
The Omnixx Force Toolbar is located directly under the Menu Bar and displays toolbar buttons 
for the most commonly used commands. The Toolbar buttons and the commands they activate 
are described below. 
 

 
Cut Button 
Removes highlighted text from its current location and places it on the clipboard. 
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Copy Button 
Copies highlighted text to the clipboard. 
 

  
Paste Button 
Pastes contents of the clipboard at the cursor location. 
 

 
Print Button 
Sends desired messages to the network printer.  
 

 
Transmit Button 
Transmits a completed transaction form for processing by the State Host. 
 

 
Message Window Button 
Displays the Message Window. 
 

 
Message Log Button 
Displays the Message Log. 
 
 
3.3  The Command Bar 
 
The Command Bar, which is located near the bottom of the screen above the Status Bar, provides 
for quick keyboard access to two commonly used features: 
 

� Exiting Omnixx Force 
� Opening a Transaction Form 

 

 
Figure 3.24 The Omnixx Force Command Bar 
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Exiting Omnixx Force Using the Command Bar: 
 

1. Click inside the Command Bar so the blinking cursor appears, or use the CTRL + G 
keyboard command to change the focus from a transaction form to the Command Bar. 

 
2. Type the word “Exit”. 

 
3. Press the ENTER key on the keyboard. 

 
4. The following confirmation box will appear. Click Yes to exit, or click No to continue 

using Omnixx Force. 
 

 
Figure 3.25 Exit Confirmation Dialog Box 

 
Opening a Transaction Form Using the Command Bar: 
 

1. In the Command Bar, type the letters “TF” followed by a space, and the Message Key 
(MKE) of the desired transaction form, then press the ENTER key.  

 
2. If a valid Message Key is entered, Omnixx Force searches for and displays the correct 

transaction form. 
 

 
Figure 3.26 Omnixx Force Command Bar – Opening a Form 

 
3. If an invalid Message Key is entered, the following error will be displayed and the user 

should repeat step one using the correct Message Key: 
 

 
Figure 3.27 Omnixx Force Command Bar – Error Message 
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3.4 The Status Bar 
 
The Status Bar, located at the bottom of the screen, below the Command Bar, provides 
information regarding the current status of your machine. 
 
 
 
 

 

C D E FB A 

Figure 3.28 The Omnixx Force Status Bar 
 

A. Switch Indicator – Indicates to which switch Omnixx Force is connected. A green 
icon indicates a successful connection; a red icon indicates the connection to the switch 
has been lost. 

 
If the connection to the switch is lost, it is possible to use this feature to attempt to 
reconnect or connect to a different switch. This can be accomplished by performing the 
following steps: 
 

� Double-click on the Switch Indicator icon. 
 
� The following “Switch IP Address?” dialog box is displayed, pre-filled with 

the switch address: 
 

 
Figure 3.29 “Switch IP Address?” Dialog Box 

 
� Leave the default IP Address, or enter a different one if desired. Click the OK 

button to continue 
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� The following “Switch Port?” dialog box is displayed, pre-filled with the 
correct switch port number: 

 

 
Figure 3.30 “Switch Port?” Dialog Box 

  
� Leave the default port number, or enter a different one if desired. Click the 

OK button to continue. 
 

� If the attempt to reconnect was successful, the icon will again turn green to 
indicate communication has resumed. 

 
B. Trace File Indicator - If the Write Trace File feature is enabled, a blue rectangle will 

appear around this box to indicate to the user that a trace file is being generated . 
 
C. Validation Code – Mnemonic or device name of the machine. 

 
D. User Name - User Name of the current user logged onto Omnixx Force. 

 
E. Message Count – Displays the number of unread messages in the Message Window. 
 
F. Time – Displays the current system time. 
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4 Using the Omnixx Force 
Transaction Forms 

 
 
 
4.1 Opening a Form 
 
The first step to running a query in Omnixx Force is to select and open a transaction form. When 
you are logged into Omnixx Force, you will only be presented with transaction forms you are 
authorized to use. Omnixx Force allows for multiple forms to be opened simultaneously allowing 
for quick access to frequently used transaction forms. Simply switch between open forms by 
selecting the desired form from the Windows menu in the Omnixx Force user interface. 
 
Using the Forms Menu: 
 

1. Click the Forms menu on the menu bar. 
 
2. Select a transaction category from the menu. 
 
3. A cascading menu will display a list of transactions for the category you selected. 

 
4. Click on the desired transaction. 
 

 
Figure 4.1 The Omnixx Force Forms Menu 
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4.2 Elements of a Transaction Form 
 

 
Figure 4.2 Omnixx Force Person Inquiry Transaction Form, or QW 

 
4.2.1 Fields and Groups 
 
A Field is a single text box that is used for entering information. 
 

 
Figure 4.3 Omnixx Force Name Field 

 
A Group is a collection of related fields in an Omnixx Force transaction form. A form may be 
comprised of one or more groups. For example, the Figure 4.4 illustrates the “Person Data” 
group. 
 

 
Figure 4.4 Omnixx Force “Person Data” Group 
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Mandatory Fields 
 
A Mandatory Field is a field that must be completed in order to transmit an Omnixx Force 
transaction form. These fields are also referred to as required fields. Blue colored text is used for 
the field label on a mandatory field; non-mandatory field labels are in black text. If you TAB out 
of a mandatory field without entering valid information, an error message, similar to Figure 4.5 
is displayed. 
 

 
Figure 4.5 Mandatory Field Not Completed Error 

 
List Boxes 
 
A List Box is a field that contains a pop-up list of valid entries for a particular field (i.e., NCIC 
codes) from which you can choose. A field that is associated with a list box is designated by a 
small button with three dots (  ) located to the right of the field. To access the menu, click on 
the box with your mouse, or use the CTRL + DOWN ARROW key command. 
 
In the following example, the “Race” field list box is shown: 
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To Select the Desired Entry: 
 

1. Open the pop-up list box 
 
2. Use the mouse to double-click on the desired entry, or 

 
3. Use the up and down arrows on the keyboard to highlight the desired entry, then press the 

ENTER key to select it 
 

 
Figure 4.6 The Omnixx Force “Race” Field List Box 

 
Some codes are located using a bi-level pop-up menu like the “Vehicle Make” menu illustrated 
below: 

 
Figure 4.7 The Omnixx Force “Vehicle Make” Bi-level Pop-up Menu 

 
To Use a Bi-Level Pop-Up Menu: 
 

1. The upper pane of the menu contains a list of categories from which to choose. 
  
2. Highlight the appropriate category and the list of possible codes for that category is 

displayed in the bottom pane.  
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3. To change the focus from the top pane to the bottom pane, press the TAB key twice or 
click in the bottom pane using the mouse. The desired code can now be selected from the 
list. 

 
4. To make a selection from the list, use the up and down arrow keys to move to the desired 

selection, or use the scroll bar on the right, then click with the mouse on the desired 
selection. Either double-click on the desired code, or press the ENTER key when the 
correct code is highlighted. 

 
Auto-Fill of Vehicle Data Based on VIN: 
 
When transmitting a Vehicle Identification Number (VIN), certain fields can be automatically 
populated based on information from the National Insurance Crime Bureau. When the user enters 
a valid number in the VIN field a prompt will appear as shown below. 
 

 
Figure 4.8 Vehicle Information Prompt 

 
From the prompt the user simply selects the fields to be auto-populated and clicks OK. The 
checked fields will appear in the format for transmission.  
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4.3 Cursor Movement in a Form 
 
Listed below are some keyboard strokes that will help you navigate quickly and easily through 
fields and groups in a transaction form. 
 

� TAB – Moves the cursor forward, one field at a time. 
 
� SHIFT + TAB – Moves the cursor backward, one field at a time. 

 
� ALT + G – Moves the cursor to the first field in the next group. 

 
� SHIFT + ALT + G – Moves the cursor to the first field in the previous group. 
 

4.4 Transmitting a Form 
 
After you have finished entering all necessary information into a transaction form, you will want 
to Transmit that form for processing by the host network. Omnixx Force allows several methods 
of transmission.  
 
To transmit the data in a transaction form, perform one of the following actions: 
 

� Click the Transmit icon on the toolbar.  
 

 
� Click on the Comm menu, then select Transmit. 

 

 
 
� Press CTRL + T on the keyboard. 
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4.5 The Omnixx Force “Right-Click” Menu  
 
Certain functions can be carried out in Omnixx Force by right-clicking on any field within a 
transaction form to display the following pop-up menu. 
 

 
Figure 4.9 The “Right-Click” Menu 

 
� Cut – Removes highlighted text from its current location and places it on a virtual 

“clipboard”. 
 

� Copy – Copies highlighted text and places it on a virtual “clipboard”. 
 

� Paste – Places text that is in the virtual “clipboard” at the current cursor location. 
 

� Undo – Reverses the last action taken in data entry within a form. 
 

� Clear – Right-click on a field and select Clear to delete all information contained in that 
particular field in a transaction form. 

 
� Clear Group - The Clear Group function gives the user the ability to quickly clear all 

fields in a group contained on a transaction form. Place the cursor in any field within the 
group, then click the Clear Group option on the menu. Omnixx Force will delete all data 
previously entered into the fields in that group and place the cursor at the beginning of 
the first field in the group. 
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For example, the figure below shows information contained in the “Agency/Case Data” 
group, “Person Data” group, and “Vehicle Data” group.  To clear the “Person Data” 
group only, tab into any of the fields in this group and click the Clear Group menu item. 

 

 
Figure 4.10 Before the Clear Group Function has been executed 

 
The next figure illustrates the transaction form after the Clear Group function has been 
executed. Notice the fields in the “Person Data” group have been cleared, but the 
information contained in the “Agency/Case Data” and “Vehicle Data” groups remain. 

 

 
Figure 4.11 After the Clear Group Function has been executed 

 

Datamaxx Applied Technologies, Inc.  48 



 Omnixx Force Training Manual                                                Version 1.0           

Note: All the fields in the form can be cleared simultaneously by right-clicking anywhere 
in the form except in a data field and selecting Clear from the menu. 

 

 
Figure 4.12 Clearing All Fields in the Transaction Format 

 
� Field Help - A feature of Omnixx Force that defines the contents of a specific field. This 

feature is useful when entering information into a transaction form and you are not sure 
of what information needs to be entered into a particular field. Right-click on a field to 
view the dialog box that displays guidelines regarding what type of information should be 
entered, as well as the correct format.  

 

 
Figure 4.13 “Name Help” Dialog Box 

 
Click OK to close the Field Help dialog box. Or click Print to send the information 
contained in the dialog box to the printer. 

 
� Mark for Deletion – Used in a Modify form, it inserts a “delete” token into a field. After 

transmitting the form, this token notifies the host that the information contained in that 
field is incorrect and needs to be deleted from the record. 
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� Replace – Opens a dialog box that allows the user to replace specific text with alternate 
text. 

 

 
Figure 4.14 Replace Dialog Box 

 
4.6  Form Help 
 
Form Help is a feature of Omnixx Force that, when accessed, displays a dialog box containing 
information about the current transaction form. 
 
To Access Form Help: 
 

� Make sure the desired transaction form is open. 
 
� Right-click anywhere in the form except inside a field, as shown below. 

 

 

“Form Help” 
Menu Item 

Figure4.15 Form Help Menu 
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� Choose Form Help from the menu and the following Transaction Help dialog box is 
opened. 

 

 
Figure 4.16 Omnixx Force Transaction Help Dialog Box for the QV format 

 
� Click OK to close the Transaction Help dialog box, or click Print to send the text to the 

printer. 
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5 The Omnixx Force Message 
Window, Display and Log 

 
 
 
In this chapter you will learn about three different types of message windows used in Omnixx 
Force. The three types include: 
 

� The Message Window 
 
� The Message Display  

 
� The Message Log 

 
5.1 The Message Window 
 
The Omnixx Force Message Window contains all sent and received messages from the current 
session. A session is considered to last from the time you log on until the time you logoff. 
Therefore, every time you login to Omnixx Force, you will begin with a clean Message Window. 
 
Although the Message Window will automatically open upon receipt of new messages, there are 
three ways to manually access the Message Window in Omnixx Force: 
 

� Click on the Message Window button on the toolbar.  
 
� Click on the Tools menu, then click Message Window. 
 
� Click the Message Counter on the Status Bar.  

 
 

 

Datamaxx Applied Technologies, Inc.  53 



 Omnixx Force Training Manual                                                Version 1.0           

 
 
 

 

A 

B 

C 

Figure 5.1 Omnixx Force Message Window 
 
 

E 

D 

F HG 

 
A. Start Date and End Date – The Start Date displays the date and time of the earliest 

message that has been received into the Message Window. The End Date displays the 
date and time of the most recent message that has been received into the Message 
Window. By default, the Message Window is sorted with newest messages listed first 
and oldest messages listed last. The user may choose to sort by Subject, Type, Image, or 
Reference ID by clicking on the appropriate column heading. 

 
B. Selection Checkboxes – Some commands allow a user to work with more than one 

message at a time. Enabling the selection box on a message indicates that the message 
is to be included in one of these commands. These checkboxes may be used for printing 
or deleting messages. 

 
C. Message Icons – These icons indicate whether a message was sent or received:  

 
   - Indicates an unread Received message. 

  
  - Indicates a read Received message. 

 
- Indicates a Sent message. 

 
D. Message Date and Time – Indicates the date and time of the message. 
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E. Message Summary – The Message Summary gives the user information regarding a 
particular message.  

 
F. Message Type – Indicates whether the message was sent or received. 
 
G. Image Indicator – Indicates whether or not there is an image embedded in the 

message. 
 

H. Ref ID – Each message associated with a single transmitted transaction format is 
assigned the same Reference ID for identification purposes. For example, in Figure 5.1 
messages with the Reference ID #00TF000007 were transmitted and received as the 
result of one transaction format being completed and submitted.  

 
Messages are by default sorted by date and time received, however, the user may elect to sort by 
any of the column headings simply by clicking on the column title.  
 
Note: If a message is delivered to the Message Window and the user does not read the message 
for a predetermined period of time, the message will automatically be displayed as shown below. 
Click OK to proceed. 
 

 
Figure 5.2 Unread Message Timeout Alert 
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5.1.1 The Omnixx Force Message Window Menu Bar: 
 
The Omnixx Force Message Window Menu Bar contains two elements: the File Menu and the 
Edit menu.  
 

 
Figure 5.3 The Message Window Menu Bar 

 
 The File Menu contains the following functions: 
 

 
Figure 5.4 The Message Window File Menu 

 
� Print 

The Print command sends the selected messages to the printer. 
 

� Exit 
The Exit command closes the Message Window. 

 
The Edit Menu contains the following functions: 
 

 
Figure 5.5 The Message Window Edit Menu 

 
� Delete 

o All – Deletes all messages contained in the Message Window. 
o Checked – Deletes only the selected messages in the Message Window. 

 
To view an individual message in the Message Window, double-click it with your mouse. The 
message is displayed in the Omnixx Force Message Display window. 
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5.2 The Message Display  
 

 

A 

D
B 

C 

Figure 5.6 Omnixx Force Message Display Window 
 

A. Menu Bar – When viewing an individual message in the Omnixx Force Message 
Display window, the Menu Bar includes two drop-down menus: the File Menu and the 
Edit Menu. 

 

 
Figure 5.7 Message Display Menu Bar 

 
The File Menu contains the following functions: 

 

 
Figure 5.8 The Message Display File Menu 

  
� Print 

Sends the current message to the printer. 
 
� Exit 

Closes the Message Display. 
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The Edit menu contains the following functions: 
 

 
Figure 5.9 Message Display Edit Menu 

 
� Copy – Places a copy of the displayed message on a virtual “clipboard” to 

be pasted to another location. 
 

� Go To - The functions First, Last, Next, and Previous listed under the 
Go To function allows you to navigate through the messages contained in 
the Message Window. 

 
o First – Takes the user to the first message listed in the Message 

Window. 
o Last – Takes the user to the last message listed in the Message 

Window. 
o Next – Moves the user forward through the Message Window one 

message at a time. 
o Previous – Moves the user backward through the Message 

Window one message at a time. 
 

B. Toolbar – The Toolbar provides for quick access to the functions found on the Menu 
Bar. 

 

 
Figure 5.10 Message Display Toolbar 

 

 Print 
Sends the current message to the printer. 
 

 First Message 
Takes the user to the first message listed in the Message Window. 
 

 Previous Message 
Moves the user backward through the Message Window one message at a time. 
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 Next Message 
Moves the user forward through the Message Window one message at a time. 
 

 Last Message 
Takes the user to the last message listed in the Message Window. 
 

C. Message Display Window – This area contains the actual text of the current message. 
 
D. Message Chronology – This area contains the following information regarding the 

current message:  
 

� The chronological number of the message in the log. 
� If the message was Sent or Received. 
� The date and time of the message. 
� The Operator, ORI, and Mnemonic associated with the message. 

 
5.3 NCIC Hits 
 
When a “hit” is received from NCIC, the following alert will appear on the screen: 
 

 
Figure 5.11 NCIC Hit Alert 

 
Click OK to continue after the alert appears. To send an automated hit confirmation request 
based on the received information, right-click on the desired message in the Message Window as 
shown in Figure 5.12 below. 
 

 
Figure 5.12 Right-Click Menu in Message Window 
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From the menu that is displayed, select the desired YQ transaction and the YQ format will 
appear with the hit information pre-filled as shown below. 
 

 
Figure 5.13 Hit Confirmation Request Format 

 
Since pertinent data is automatically pulled from the hit message, the user needs only to enter 
remaining mandatory fields for transmission: Hit Confirmation Request Number (RNO), Priority 
(PRI), Requestor Name (RNA), and Requestor Agency (RAG).  
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5.4 Switch Error Messages 
 
When a transmission error is received from the State switch (i.e., invalid data submitted) the 
following alert will appear: 
 

 
Figure 5.14 Switch Error Message 

 
Click OK on the error alert to continue. The message can be corrected and resubmitted quickly 
and easily by taking the following steps: 
 

1. Right-click the error message and select Display Error in Original Form as shown 
below.  

 

 
Figure 5.15 Display Error in Original Form Menu Option 

 
2. The following message will appear: 
 

 
Figure 5.16 Error Message Alert 
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3. Click OK to continue and the original transaction form is displayed with the original data 
in the fields as shown in Figure 5-17. 

 

 
Figure 5.17 Original Transaction Form Presented to the User for Correction 

 
4. Make necessary changes and re-transmit. 

 
5.5 The Message Log 
 
The Omnixx Force Message Log allows you to search for and view messages that have been 
previously deleted from the Message Window.  

 

  

A 

D
B 

C 

Figure 5.18 Omnixx Force Message Log 
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A. Menu Bar – The Message Log Menu Bar contains two elements: the File menu and the 
Tools menu. 

 
The File menu contains the following function: 

 

 
Figure 5.19 Message Log File Menu 

 
� Exit 

Closes the Message Log. 
 

The Tools menu contains the following function: 
 

 
Figure 5.20 Message Log Tools Menu 

 
� Archive 

Archives the current log and begins a new log. 
 

B. Search Criteria – The user can narrow a search by entering information into the Search 
Criteria fields. The user can make the search as broad or as narrow as desired by 
entering as much or as little information as is available into the following fields:  

  
� ORI – The ORI associated with the message. 
� Term – The terminal ID associated with the message. 
� Unit – The logical unit number of the message. 
� Operator – The operator ID associated with the message.  

Note: This field will automatically default to the current user’s User ID and 
cannot be changed to allow the user to view messages sent and received by 
other users. 

� Start Date – The search covers messages that were logged beginning with this 
date.  

� End Date – The search covers messages that were logged up to this date.  
� Start Time – The search covers messages that were logged beginning with this 

time.  
� End Time – The search covers messages that were logged up until this time.  
� Search For – A user may enter specific text that is contained in the message 

they are searching for. 
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� MKE – Enter a message key to search for messages related to a particular 
transaction form (i.e., QV). 

� Type – Allows the user to narrow down the search to Sent, Received, or All 
messages (defaults to All). 

 
To Add an Archived Log to Your Search: 
 
To include a log that has been previously archived in your search, perform the 
following steps: 
 

� Enter the desired Search Criteria and then click the Logs tab on the Message 
Log window. A list of all Archived Logs is displayed: 

 

 
Figure 5.21 The Message Log “Logs” Tab 

 
� Select the Log(s) to be included in the search by activating the corresponding 

checkbox(es), or click the Select All button to include all archived logs in the 
search. 

 
� Click back to the Criteria tab and click Search. The selected Archived Log(s) 

are now included in the message search. 
 

C. Message Display Window – All messages that meet the criteria specified by the user in 
the Search Criteria fields are displayed. The information displayed for each message 
duplicates the same information displayed in the Message Window. 
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D.  Command Buttons  
 

� Search – Click the Search button to display the results of your search.  
 
� Print – Sends selected messages to the printer. 

 
� Exit – Closes the Message Log. 

 
5.6 Forwarding a Received Message 
 
In Omnixx Force, it is possible to forward a message that you have received to another user. This 
is possible from either the Message Window or the Message Log. The information from the 
message is automatically entered into an Administrative Message for transmission. 
 
To Forward a Received Message: 
 

1.  From either the Message Window or Message Log, right-click on the selected 
received message and the following menu will appear: 

 

 
Figure 5.22 Right-Click Menu 

 
2. Click on Forward Message. 
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3. An Administrative Message is opened and populated with the information contained 
in the message and can then be sent to the desired agency. 

 

 
Figure 5.23 Forwarded Message 

 
5.7 Alternate Ways to View a Sent Message  
 
In Omnixx Force, it is possible to view a sent message from the Message Window or the 
Message Log in two different ways. These alternate options are: 
 

� Display Base Form. 
 
� Display in XX Format. (Where XX stands for the Message Key of the message.) 
 
To Display a Message in Base Format: 
 

1. From either the Message Window or the Message Log, right-click on the desired 
sent message. The following menu is displayed: 

 

 
Figure 5.24 The Right-Click Menu 

 
 

2. Click on Display Base Message. 
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3. The message is opened in a Message Display window in a form that lists all 

information exactly as the user entered it. 
 

 
Figure 5.25 Display Base Message 

 
To Display a Message in XX Format: 
 
This function allows you to select a sent message and repopulate the information into the 
transaction form in which it was originally entered. This function is helpful if you realize you 
entered and transmitted incorrect information and you would like to quickly transmit the 
form again with the correct information. 
 
Note: XX represents the Message Key of the transaction form that was originally transmitted. 
In the following example, you will notice XX is replaced with QV. 
 

1. From either the Message Window or the Message Log, right-click on the desired sent 
message. The following menu is displayed: 
 

 
Figure 5.26 Right-Click Menu 

 
2. Click on Display in QV Format. 
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3. The information contained in the message is now displayed in the transaction form as 
it was originally entered. 

 

  
Figure 5.27 Message Displayed in QV Form 

 
4. You can make any desired changes to the information, and easily transmit the form 

again. 
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6 Receiving and Sending Images in 
Omnixx Force 

 
 
 
Due to technological advances in the software field, it is now possible for images to be 
embedded in messages that are passed over the vast law enforcement network. This allows mug 
shots, fingerprints, and other identifying photos to be viewed by a user, as well as allowing for 
the entering and transmission of these same items.  
 
6.1 Receiving an Image 
 
When a message is received into the Message Window that contains an image, the Image 
indicator for that particular message will display a “Y” to notify the user. 
 

 

Image 
Indicator

Figure 6.1 Omnixx Force Message Window 
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To view the image, simply double-click on the message and the Message Display window will 
open. The image will automatically appear as shown below. 
 

 
Figure 6.2 Received Message with Embedded Image 

 
 
6.2 Entering an Image 
 
There are various transaction forms that can be used to enter an image, depending on the type of 
image that needs to be submitted. For the example in Figure 6.3, we will enter a photograph of a 
stolen vehicle for transmission to NCIC. 
 
To Enter an Image: 
 

� Open the desired transaction form from the Forms menu. 
 

 
Figure 6.3 The Imaging Submenus 

Datamaxx Applied Technologies, Inc.  70 



 Omnixx Force Training Manual                                                Version 1.0           

� The form you selected is displayed as shown in Figure 6.4. 
 

 
Figure 6.4 Omnixx Force “EIM” Transaction Form 

 
� Enter the ORI, Make, Style, Model, and Year of Manufacturer: 
 

 
Figure 6.5 Omnixx Force “EIM” Transaction Form 

 

Datamaxx Applied Technologies, Inc.  71 



 Omnixx Force Training Manual                                                Version 1.0           

� Click the button  to the right of the Image field to open the following dialog box: 
 

 
Figure 6.6 Image Loading Dialog Box 

 
� Click on the Load File button to open the browser box to search for the image file on 

your computer’s hard drive:  
 

 
Figure 6.7 Image File Browse Box 
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� Highlight the desired file and then click the Open button to insert the file. 
 
� The Image Loading dialog box will then display the selected image in the upper left-hand 

corner. 
 

 

A

B

C

D

F
E 

Figure 6.8 Image Loading Dialog Box 
 

A. Load File – Opens the browser to allow the user to search for the file to be transmitted. 
 
B. Crop Image – Allows the user to crop the image if it is too large to be transmitted. 
 
C. Image Ready – After the image has been loaded and adjusted, click this button to 

complete the image loading process. 
 
D. Image Type – Select the type of image being transmitted from this drop-down selection 

box. 
 

E. Contrast, Brightness, Zoom – Use Contrast and Brightness to adjust the clarity of the 
image. Use the Zoom scale to zoom in or out as required. If the picture is larger than the 
allowed space, scroll bars will appear to the right and below the picture for further 
adjustment. 
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F. Cancel – Terminates loading of the image.  
 

� Once the image has been loaded, make any desired adjustments to the settings 
described above. 

 
� Click the Image Ready button to proceed. 
 
� If the selected image is too large for transmission, the following error message is 

displayed: 
 

 
Figure 6.9 Error in Image Size Dialog Box 

 
� Click the OK button to close the error message and use the Zoom feature to 

reduce the size of the image. 
 

� Once the image has been scaled down to an acceptable size (less than 31,000 
bytes), click the Image Ready button again to proceed. 

 
� The image is now loaded into the EIM transaction form and ready for 

transmission. 
 
 

Datamaxx Applied Technologies, Inc.  74 



 Omnixx Force Training Manual                                                Version 1.0           

Appendix A – Keyboard Commands 
 
 

KEYSTROKE FUNCTION 

CTRL + A 
Archives the messages currently in the Message 
Log 

CTRL + C Copy 

CTRL + V Paste 

CTRL + X Cut 

CTRL + G 
Toggles focus between the active form and the 
command bar 

CTRL + F6 Toggles through all open forms 

ESC Closes the current active form 

ALT + G 
Moves the cursor to the first field in the next 
group 

ALT + SHIFT + G 
Moves the cursor to the first field in the previous 
group 

CTRL + L 
Deletes all messages in the Message Window 

CTRL + K 
Deletes the checked messages in the Message 
Window 

CTRL + P Print 

CTRL + E Exit 

CTRL + F Go to first message (Message Display) 

CTRL + L Go to last message (Message Display) 

CTRL + N Go to next message (Message Display) 

CTRL + R Go to previous message (Message Display) 
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